Xerox Phaser 7500DN not printing fonts correctly

Started by DigiCorn, October 18, 2017, 04:03:27 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

DigiCorn

We just brought the old Xerox Phaser 7500DN from the other shop to this location and are using it. The problem is, it is not downloading fonts when printing. It doesn't matter if you print direct from InDesign or a PDF with fonts embedded; it substitutes certain fonts. It also will not allow "Print as image," from Acrobat. Nothing on the Xerox forums about this and on the configuration page, I don't see an option to turn on downloading of fonts.
"Selling my soul would be a lot easier if I could just find it."
– Nikki Sixx

"Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut."
― Ernest Hemingway

Joe

The user manual lists under Standard Features "Postscript and PCL fonts" which makes it sound like there is a problem with the printer. I would try resetting it back to factory defaults and get a clean start. And also make sure the firmware has been updated to the latest available. Also are you using the latest drivers for it?
Mac OS Monterey 12.4 | (retired)

The seven ages of man: spills, drills, thrills, bills, ills, pills and wills.

DigiCorn

The font is a True Type font and not corrupted. Printing from  Mac Pro running Sierra 10.12 (not High Sierra) and using the latest version of the driver (4.8 b 1912).
"Selling my soul would be a lot easier if I could just find it."
– Nikki Sixx

"Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut."
― Ernest Hemingway

Joe

Mac OS Monterey 12.4 | (retired)

The seven ages of man: spills, drills, thrills, bills, ills, pills and wills.

DigiCorn

"Selling my soul would be a lot easier if I could just find it."
– Nikki Sixx

"Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut."
― Ernest Hemingway

Possum

Last resort: open up the PDF in Photoshop and print that. Then call Xerox tech support. Maybe there's a belated tweak in the software you didn't get yet.
Tall tree, short ropes, fix stupid.

mc hristel

Do you have the machine set to face true north or magnetic north? 

Maybe moving it to it's new location upset it's alignment with a local ley line? 

Just throwing out ideas here since I would assume that nothing was changed between when it was working before and now.

David

swing a dead chicken over your head....

throwing ideas out there too!

 :rotf:
Prepress guy - doin' jobs one at a time
www.texasgraphics.com

pspdfppdfxhd

Quote from: DigiCorn on October 19, 2017, 09:14:55 AMIt works, but thickens the type on the output
Some people like their type "thick".

You might get away with it.

 :drunk3: