B4Print.com

Workflows => Agfa Systems => Topic started by: David 1122 on May 02, 2019, 04:08:56 PM

Title: Apogee X vers. 2.5 compatible?
Post by: David 1122 on May 02, 2019, 04:08:56 PM
Hello!

I am currently running AGFA Apogee X vers. 2.5 on the computer at my work which uses Windows 7 as an OS. I just got the notice that 7 will not be receiving security updates as of Jan. of next year. Does anyone know if this version of Apogee is compatible with Windows 10?

Any info or feedback would be greatly appreciated!

-David